Start a new topic

Android App compability

For some reason the Android app stopped working can this be fixed, please? Having purchased the Aircross 3 I have no way of utilizing things like the timelapse because there isn't an app I can use for it. 

Is your phone up to date?

Is your Moza Genie app up to date?

Or is it the Moza Master app? I might have been incorrect in saying Moza Genie app. 

it's the master app, it will download but won't install I've even tried to use an APK for it but something is keeping it from installing. 

I would suggest filling out a new support ticket as it is very obvious the Moza apps, both of them, haven't been working properly for many people.

Thanks Nick I have a ticket in, they basically told me to update my we will see where that goes. 

It seems Android users are having a harder time getting the apps to work than iPhone users as all the issues I have read about between phones and moza apps have to do with Andriods. 

Absolutely, they did post an update to the app on the 24th so it installs now but crashes when you try to connect the gimbal. I guess one step at a time. 

1 person likes this
Is the moza master app fixed ? It still crashing when trying to connect on android...

2 people like this
Master app won't connect with slypod pro...

Tuan, it's not at current,  support sent me a link to download the APK and the package they sent won't install on my phone.  If they give me a solution that works I'll post it here so that you and the other Android users have it, if anyone else gets this working please let us know what you did. 

1 person likes this
Moza asked me to download apk via a url link, but i already tried that. It's the same app from Google store and still crashes and exits app while scanning.

Same, I couldn't even get the APK to install when I tried it. 

A message shown after I download APK file and try yo install: "There was a problem while parsing the package". Did some research and tried to give permissions to install third parties, remove firewall and antivirus... still can't install apk.

That's the issue I ran into with the APK, I even tried a third-party APK installer with no luck. Not sure what the deal is and why support is having so much trouble with the latest android update but it seems to be causing all kinds of chaos with their app. I may just pick up a cheap ipad to be able to use all the functions of this gimbal but it sucks having to do that. 

Login or Signup to post a comment