Start a new topic

My Moza Mini MX doesn't work

I load my phone & turn in on. It picks the phone up & moves it into place then suddenly drops. The longest it held the phone up was around a minute. The phone is balance, it just won't hold it up. It's like it shuts off but it's still on.


Are you using the original MX or the MX2? Make sure you have everything unfolded and all the motors unlocked. Double check with the instructions that came with it that you’ve done this.

The original MX. And yes I made sure everything was unfolded and unlocked. I have a friend that isa big YouTuber that has the same gimbal, in fact he is the reason I bought it. I checked with him and he told me to check all of that as well. I did file a new support ticket. I have the Samsung Galaxy S22, my case is very hard to get off & it fits with the case on but I did fight with it & get it out of the case and it still did the same thing. It's like it shuts off but it's still on.

Is your phone too heavy for the gimbal?

I don't think so. Like I said I did take it out of the case, even though it's hard to get it on & off. And it did work the longest when the case was on.

i have the same problem and it solved.. you need to hard reset the gimbal.. just push the very small hole below the charging port with needle.. everything will fix and works properly..

I tried that but it still didn't work. I'll try again & hopefully it will work.

Login or Signup to post a comment