Start a new topic

Moza Nano SE remote controller problem

Hello good people,


I owned a Moza Nano SE, and it was working fine until today. The detachable remote controller has suddenly become non functional. the mini light on the remote flashes but nothing happens on the camera app / or the gimbals. Press M button suppose to make the gimbal move between horizontal and vertical without supporting any app, but that doesn't even happens.


Does the remote controller has battery? how do it charge it self?

can i change the battery of the controller?

Can anyone help / suggest me what to do to solve the problem?


1 person has this problem

Could you please download the moza genie app to check if it still has the same problem?
‚Äč
If you use moza genie app, please don't connect your native bluetooth, you need connect your gimbal in moza genie app directly. Check the followings

image


 

I have also the same problem. Please guide to fix the problem. Thanks

I have almost the same problem. Only, my menu (top) button is working fine. But none of the others. (I am using the Moze Genie app.)

I tried both the bluetooth reset and the pairing described above but none of them worked.

Please suggest what can be done, product is still under warranty
Login or Signup to post a comment