Start a new topic

Air 2 Not Powering On Properly

Hoping someone can help. My Air 2 used to work fine no problems. But yesterday it has developed a peculiar issue. I put the batteries in it, and the Moza logo comes on and stays on, without pressing anything. The gimbal itself isn't on, just the LCD screen and logo always on. Press the power button, the gimbal turns on and works as it should no problem. Hold the power button, it turns off, no problem. But if you press the power button again, nothing happens. It won't power back on. But, if I hold the menu button down, the gimbal turns back on, but the LCD screen doesn't. But now the power button won't turn the gimbal off. Only holding the menu button into sleep mode works. But there is still no life from the LCD. The only way to get the LCD back on is take the batteries out and put them back in. And I also can't get it into boot mode. Tried resetting through the settings menu. Batteries are fully charged. I haven't tried using the external battery pack yet. Any thoughts, tips or ideas would be much appreciated.

2 people have this problem

I have a same problem, 

I am also experiencing the same problem as described. Unfortunately, it doesn`t look like Gudsen is responding to the topics posted on this site.

Login or Signup to post a comment